[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

kernel too old



Jeg oplever ind i mellem at noget jeg har kompileret og linket statisk ikke kan køre på en ældre maskine.

Programmet fejler med: kernel too old.

Det er jo naturligt nok for så vidt.
Spørgsmål:

1) Hvordan afgør jeg udfra et statisk linket program hvilken kerne den kræver?

2) Hvilke faktorer bestemmer hvilken kerne mit program kræver?
   * Kernen på udviklingsmaskinen?
   * Compiler version?
   * Anvendte features i programmeringen?

3) Er der nogle særlige velkendte spring mht til kompatibilitet, a la: programmer bygget med kerne 2.6.x eller derover vil aldrig kunne køre på mindre end kerne 2.4.y eller lignende...

/ Kristian
( Ubuntu 10.04 )





 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2010-07-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *