[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [NOVICE] grub problemer



Sonne wrote:
Kære forum.
Jeg er kørt fast. Har læst en masse om grub(mange rigtig gode sider !) men der må være noget jeg overser.
Jeg har en fc4 kørende med grub som boot loader. disken sidder som primære disk på ide0. Det kører. Jeg sætter en disk fra en anden maskine i på ide1 som slave(der sidder en cd-rom som master).
På den nye disk findes en FC5 som tidligere har kørt uden problemer. Jeg mounter den nye disk(hdd1) og finder dens grub.conf og klipper boot paramererne ind i grub.conf på min fc4 disk (hda1) og retter den til: default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.16-1.2069_FC4)
root (hd0,0)
kernel /boot/vmlinuz-2.6.16-1.2069_FC4 ro root=LABEL=/1 rhgb quiet acpi=force
initrd /boot/initrd-2.6.16-1.2069_FC4.img
title Fedora Core (2.6.15-1.2054_FC5)
root (hd1,0)
kernel /boot/vmlinuz-2.6.15-1.2054_FC5 ro root=/dev/hdd1 rhgb quiet acpi=force
initrd /boot/initrd-2.6.15-1.2054_FC5.img


Men når jeg forsøger at boote FC5 skriver grub "file not found".Grub ser åbentbart ikke den nye disk ? Hvis jeg under boot, kalder grub komandolinien bekræftes denne observation idet der ingen ændring er i den kerne der findes om jeg skriver root (hd0,0) [ENTER]
find /boot/vml[TAB]


eller
root (hd1,0) [ENTER]
find /boot/vml[TAB]

Jeg kan ligesom ikke få grub til at kikke på hd(1,0), hvorfor ikke?

Hvis min fc4 kører og jeg i en shell skriver "grub" og venter på grub kommandolinien kan den godt finde både fc4 kernen på (hd0,0) og fc5 kernen på (hd1,0). Er der mon nogle der ser hvad jeg gør galt.?

hdd1 hedder i grub (hd3,0).

--
Med venlig hilsen

Jørgen Heesche
mailto:sslug@sslug
Registered Linux User #401007


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2007-02-01, 02:02 CET [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *