[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [MISC] Kan man stole på Debian dependencies?



Donald J Axel <sslug@sslug> writes:

> Der er ingen, der beklager sig. Men se lige her:
>
> saturn:/hjem/sysadm/pakk #xpdf
> Warning: Cannot convert string "-*-courier-medium-r-*-12-*-*-*-*-*-iso8859-1" to type FontStruct
> saturn:/hjem/sysadm/pakk #aptitude -s install xpdf
> The following NEW packages will be installed:
>   cups-bsd{a} cups-client{a} cups-common{a} gsfonts-x11{a} lesstif2{a} libfile-copy-recursive-perl{a} libxp6{a} 
>   poppler-utils{a} samba-common{a} samba-common-bin{a} smbclient{a} update-inetd{a} xpdf 
> The following packages will be upgraded:
>   libcups2 
> 1 packages upgraded, 13 newly installed, 0 to remove and 27 not upgraded.
> Need to get 12.0 MB/12.1 MB of archives. After unpacking 70.4 MB will be used.
> The following packages have unmet dependencies:
>  libcupsimage2 : Depends: libcups2 (= 1.5.3-2.14) but 1.5.3-2.15 is to be installed.

Se den er lidt mystisk, for libcupsimage2 og libcups2 kommer fra samme
source-pakke. Så hvis en specifik version af den ene er tilgængelig i en
Debian-release så er det ret usansynligt at samme version af den anden
ikke er tilgængelig.

Begge pakker skulle også være tilgængelig i Debian Testing i version
1.5.3-2.15. Jeg har ikke rigtig nogen ide til hvordan det kan gå galt,

[...]

> Accept this solution? [Y/n/q/?] quit
> # ---
>
> Hvorfor vil Dep-tree fjern ghostscript?

Fordi libghostscript afhænger af libgs9, som igen afhænger af
libcupsimage2. Dermed skal den fjerne ghostscript for at få lov til ikke
at have libcupsiamge2 installeret. 

> og hvorfor i al verden vil den installere smbclient? Det er nok igen
> LSB som trækkes ind.

Nej det er ikke LSB der spilelr ind. Det vilel også være højst
usandsynligt når du ikke forsøger at installere tredjeparts pakker.

Men xpdf anbefaler cups (for at kunne skrive ud) og cups anbefaler
smbclient (for at kunne tilgå windows-printere). Begge dele er dog
valgfrie og det står dig frit for at ignorere den ene eller den anden
anbefaling hvis du ved at du ikke har det specifikke behov.

> Som du kan se har jeg kopieret en XPDF over fra en anden distro
> sammen med tre library filer og kørt ldconfig, og derefter kører
> xpdf  (og brokker sig over en manglende courier, men det kan også
> løses).

Øhmmm, det lyder da godt nok dumt. xpdf virker glimrende i Debian.

>
> Jeg tror at Debian-deps tree er blevet så stort, at det er nemmere
> at installere "sjældne exemplarer" (programmer, som andre ikke
> bruger) fra source.

Jeg tror at det er dig der gør det forkert.

Nu vil jeg ikke ligefrem kalde xpdf et sjældent eksemplar. Men efter min
mening så forholder det sig absolut lige omvendt. Det er ofte de obskure
programmer hvor jeg får mest nytte af bare at hente pakken fra Debian
uden at skulle bekymre mig om at finde en Modula-3 oversætter eller at
skulle bootstrappe ghc selv.

For mig ser det ud til at du bruger mange resurser på skumle omveje
fordi Debian ikke er helt specifik skrædersyet for dig. Du har fået at
vide hvordan du får Debians pakkesystem til at ignorere anbefalinger og
kun hente nødvendige afhængigheder.

Du har ligeledes i en anden tråd fået at vide hvordan du selv tager
ansvaret for at generere et nyt initramfs når der bliver installeret nye
versioner af kernemoduler. (Hvordan du så vil afgøre det, jeg er
tilfreds med at Debian bare virker automatisk.)

Det er altså ikke besværligt!

> Linux Mint-1x out-of-the-DVD har været i stand til at dække de
> fleste af mine behov, men jeg ville gerne prøve en Debian m.
> X11-TWM, MPlayer, VLC, Kino, LibreOffice-4.0.1, Firefox-19 m.
> Adobe-flash-11.2, Java-1.7.17 og som nævnt xpdf.

Flash og Java skal jeg ikke lige kunen udtale mig om, men hvis du nu
vælger at lade være med at gøre ting ekstra besværlige for dig selv så
kan jeg ikke se hvorfor ikke Debian skulle kunne dække dine behov lige
så direkte som Mint.

Det er i hvert fald ikke på grund af de "problemer" som du har beskrevet
de sidste uges tid.

//Makholm



 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2013-04-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *