[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [MISC] Kan man stole på Debian dependencies?



On Thu, 07 Mar 2013 10:06:22 +0100
Peter Makholm <sslug@sslug> wrote:

> Donald J Axel <sslug@sslug> writes:
> 
> >> On 03/06/2013 01:13 PM, Donald J Axel wrote:
> >> ...
> >> > Hvordan kan jeg rette mine dependencies? Dette er jo åbenlyst
> >> > forkert, der må være gået noget galt i dpkg-status eller
> >> > noget?
> >> ...
> 
> ...
> 
> > Nej, det er fordi Google-udviklerne forudsætter lsb-core
> > standard overholdes, og så har Debian bare tilføjet hele
> > LSB-core, hvilket naturligt nok omfatter en C-compiler m.v. Når
> > man simulerer install lsb-core, kommer den med samme lange
> > liste.
> 
> Du kan vel egentlig ikke bebrejde Debian for at en pakke leveret
> af Google har unødvendige afhængigheder?
> 
> Men det er ikke korrekt at LSB kræver en C-compiler med mere.
> Tanken bage LSB er ikke at specificere ensartede
> udviklings-miljøer, men at skabe en basis-platform velegnet til
> distribution af slut-bruger programmer.
> 
> En grundsten i LSB er at software distribueres i RPM filer. For at
> integrere dette i et Debian-system skal pakken derfor konverteres
> med alien. Alien afhænger (selfølgelig) af dpkg-dev, som igen har
> en "Recommends" på en række basale udviklingsværktøjer. Som
> tidligere påpeget vil du kunne læse dit problem ved ikke at
> installere pakker med en Recommends-afhængighed.
> 
> Men lige så snart Google vælger at distribuerer somftware som en
> deb pakke, så har de allerede gået ud over LSB og så burde de
> også tage sig sammen og definerer fornuftige afhængigheder. Så
> igen, det er vel ikke retfærdigt at du beskylder Debian for at
> Google laver dårlige pakker i det pakke-format som Debian
> tilfældigvis har defineret.
> 
> //Makholm

Jeg bebrejder selvfølgelig ikke Debian-package crew noget som helst,
tværtimod er det et fremragende stykke arbejde. Jeg blev bare
perplex over at se den meddelelse om hvor mange pre-requisites
(med-installationer, pakker som GoogleEarth var afhængig af) så
jeg måtte skrive lidt :) inden jeg løste problemet, - det *blev*
løst, og det var ikke så svært.)

Det er klart at det er Google, som har lavet dep.listen til
GoogleEarth-7 pakken.

OG: det er ikke Debian, som har lavet deps i lsb-core, det
er http://www.linuxfoundation.org/collaborate/workgroups/lsb

Og jeg skrev vist også at jeg hæfter mig ved at Debian ved
installation af lsb-core advarer om at Debian ikke er LSB-compliant
og ikke har tænkt sig at være det. Det er selvfølgelig også OK, selv
om det i en større sammenhæng må ses som et problem at der er 
mange Linux distributioner, som laver noget der minder om
technical lock-in, når vi beder andre producenter om at være mere
åbne, mere standard compliant.

Tak for kommentarer og hjælpsomme svar! og husk det nu, det var
ikke en klage over Debian, som er en af de mest stabile - om ikke
DEN mest stabile - Linux distribution.

-- 
Donald Axel <sslug@sslug>


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2013-04-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *