[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

X med Nvidia bruger 136 MB RAM



Hey folks.

På IT-C har vi en del maskiner med gamle nvidia geforce 2 et eller andet
kort, og nogle nyere, med GeForce4 MX420 (samt et par stykker med MX440).

Folk vil gerne kunne udnytte at kortene kan OpenGL, så derfor har vi
skiftet den almindelige nv driver ud med Nvidias egen.

For et par semestre siden, før vi fik GeForce4, gik det meget godt. Jeg
installerede den nyeste Nvidia driver når vi lavede nye images, men så fik
jeg pludselig klager over at X brugte 130 MB RAM!

Det viste sig at være korrekt. Men den nyeste nvidia driver brugte X
meget meget mere RAM end med de ældre Nvidia drivere, eller nv driveren.
136 er den oppe på nu (top og så "M" viser 136M ud for X). 

Det er surt når man kun har 128 MB RAM eller endda 256, at X stjæler så
meget :-(

Så jeg geninstallerede en gammel nvidia driver og alle var glade. 

Den gamle nvidia driver virker imidlertid ikke med GeForce4 kortene. Så
nu er jeg nødt til at vælge mellem at give folk OpenGL eller give dem
ledig RAM. Enten får de ingen openGL, eller også er 136 MB af maskinens
128 MB allerede optaget fra start. No fun.

Er der nogen der ved hvad det går ud på? Er det fordi de har puttet
understøttelse for flere kort ind i samme driver, at det fylder så meget? 

Er det slet ikke et problem andre steder, har I andre bare en GB RAM og
er ligeglade?

Eller er det kun hos mig at X tager så meget? Jeg "compiler" fra tgz
filerne. RPM'erne findes aldrig til de kerner jeg skal bruge,,, Vi kører
Red Hat men ofte med en kerne fra Red Hats updates, der er nyere end den
der fulgte med distributionen.

Er der nogen compile options der kan mindske memory forbruget?

Eller nogen XF86Config-4 options? Jeg har læst README filen og ikke
blevet meget klogere. NoLogo hjælper ikke, eller også sætter jeg den ind
det forkerte sted, og der skal jo nok også mere til end det..

TIA
-- 
Hanne Munkholm <sslug@sslug>

BOFH excuse of the day: We're upgrading /dev/null


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 20:50 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *