Kapitel 1. Installation af Docbook værktøjer

For at bruge DocBook skal der installeres en del pakker, og de skal installeres i den rigtige rækkefølge. Herunder er et script, der installerer alle de nødvendige pakker. Det skal lige nævnes at de tilsammen fylder 114MB. Installerer du Red Hat 6.2, kan du nemt installere alle værktøjer til at skrive i DocBook:

[root@MinMaskine /root]#  cd /mnt/cdrom/RedHat/RPMS
[root@MinMaskine RPMS]#  rpm -Uvh sgml-common-*
[root@MinMaskine RPMS]#  rpm -Uvh docbook-*
[root@MinMaskine RPMS]#  rpm -Uvh stylesheets-*
[root@MinMaskine RPMS]#  rpm -Uvh jade-*
[root@MinMaskine RPMS]#  rpm -Uvh sgml-tools-*

Skal du kunne oversætte SGML til Postscript eller PDF skal du også installere LaTeX værktøjerne:

[root@MinMaskine RPMS]#  rpm -Uvh dialog-*
[root@MinMaskine RPMS]#  rpm -Uvh tetex-fonts*
[root@MinMaskine RPMS]#  rpm -Uvh tetex-[1-9]*
[root@MinMaskine RPMS]#  rpm -Uvh tetex-xdvi-*
[root@MinMaskine RPMS]#  rpm -Uvh tetex-latex*
[root@MinMaskine RPMS]#  rpm -Uvh tetex-dvips-*
[root@MinMaskine RPMS]#  rpm -Uvh jadetex-*

Dog skal du vide at der er kommet tre nye RPM-pakker i forhold til den originale Red Hat 6.2. Disse pakker skal du opgradere til.

[root@MinMaskine RPMS]#  rpm -Uvh ftp://ftp.redhat.com/6.2/noarch/docbook-3.1-4.noarch.rpm
[root@MinMaskine RPMS]#  rpm -Uvh ftp://ftp.redhat.com/6.2/noarch/sgml-common-0.1-8.noarch.rpm
[root@MinMaskine RPMS]#  rpm -Uvh ftp://ftp.redhat.com/6.2/noarch/stylesheets-1.54.13rh-1.noarch.rpm